Cash App
Cash Card Transactions Declining
Incident Report for
Cash App
Resolved
Our team has resolved the issues affecting some Cash Card transactions. All transactions should now be working as expected.
Posted
Sep
18
,
2023
-
16:14
PDT
Investigating
We’re currently investigating reports of issues with Cash Card transactions declining. We’re working on a solution and will share another update soon.
Posted
Sep
18
,
2023
-
15:18
PDT
This incident affected: Cash Card and In-App Alert.
×
Subscribe to Incident
Subscribe to updates for
Cash Card Transactions Declining
via . You'll receive .